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sl giws 5l eolaiul ch
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il b, asly ol (il )35 51 e 51,8

o] el
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LINE le ol o peebaZo)ly oyl o cnl 5l eslaal b -
3959 S by aed l aly o B nl slp oS

Ribbon :Home tab»- Draw panel » Line e el labais ol

Menu :Draw » Line

Toolbar :Draw /

= Command entry :line or |

el Lyl BB 9,409, slo o, 5 (S 4 j9ms ol

COMMEAND: LINE coerreeeeemmrerseeesssssssesseeesssssssssssssesssssssssssssessssssssessssssssssssssssssesssssssssssssssssseces s (gl )
Specify first point: oo (Sl 00l SIS gl byl o p0d 40 ) S aseiio |y ol alads -Y
Specify next point or [Undo]: 4 e (pgo alaii) .auS astive | son alads -Y
Specify next point or [Undo]: 3 e (pgw aadl) WuS jasive |, gox aki -¥
Specify next point or [Close/Undo]: 4 ... (ool ahai) S asin|) gow ahii -0

Specify next point or [Close/Undo]: ¢
abat 4 alads 31 ol oS 0,88 g leyd b 0 C B> ol g Close jgiws 5l soliul b ¢
gl se @ s 5l il alS (50,88 L & jgoinl 28 )3 5 e pled jgiws 5 ode )

next point L=4 3next point
< el 0o soliwl O1tho lpl 51 IS cpl s 5 50 -

™ ™
I 1
— + * —

Close 5 — 5

1 L=4 next point

start point

S a5 03,5 iy sative bl 59, LipSe 095 e el : Snap = F4

oS o bl gz o T Jsb 59,58l b b |, sogas o bl bghas aslsi oo 2l oyl 45 : Ortho = FA
D9 0L Jloasgly bglas w5 Cae o 390 oo el 3l ol - Polar Tracking = Fy o

Aok 5 03,5 B> | loyd Las S ol 4 algs o LIl cpl 5l eslazsl L :Dynamic Input = FyY
« Polar Tracking 4 Ortho U |5l cpl auics poai axio 0 |, oSl slaply 5 (539,9 Sledlbl
S oo 5 sy

Dg g0 0010 sl JulS jeb 4y Sty e ;0 YU o oal ol 3

YA
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XLINE ol B 3o s P B e utes ol Sl esliil -
Ribbon :Home tab» Draw panel » Construction Line Mb WLG‘J‘-?

Menu :Draw » Construction Line

Toolbar :Draw /

oo .
B3 Command entry :xline or x|

Ll Lzl BB g9, slasog, 51 (SO jgiws ol

Command: XLINE vl ) 5w (G121 =)
Specify a point or [Hor/Ver/Ang/Bisect/Offset]: - b 1S 0 lgicds dads SO 40,5 adein -V
SPECify tNrOUGN POINE: ooooeeeeerecceeeeeerrecsssssssesecessssssessseessssssssssssessssssssessseesssss pgd aladi 10,5 o)l Y
Specify through POINE: .o pow aladi 50,5 5l -
Specify through POINt: oo oylez alads 0 5 5 lg -0
SPECify throUGh POINE: oot oy aladi 18 ST lg -F

COMMANG: XLINE  ceeeeereeereceesusneeessssmnessssssmeesssssmesssssssesssssssmessssssnssssssssessessssnssssssnsessssssnessssssnsssssens gewd gl
Specify a point or [Hor/Ver/Ang/Bisect/Offset]: h ..o a8l a8 5l eolatl

;58 Hor —
S5 oo mmmt 5 g g2 B 58 B8l s S S aseieal (slabai 45 i sl 43S ! 5l ool b

i35 Ver -
N
wawfw%@d#sor{alﬁb&’c..\.u.SGSJMbd‘dbmdsds.?w.«odb)b@;w‘)‘oéw‘b

Y4



Slasle gbaisi g o5gil R D L

DS o 5 ol o B,k 90 Sl jatuine asgly b s G alg e a5 ol 5l eolaiwl b aggl; Ang -

ComMMEANd: XLINE  ceeeeeessmmmseessessmmssssesssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssasnasssssssssss D ygiwd gl
Specify a point or [HOr/Ver/ANg/BISECH/OMSE]: 8  rrrsrrimsrssimsssississsssieses, agly 43S
Enter angle of xline (0) or [REfErence]; 45 i Lz agly 0,5 0l
SPECGiy through point: s alads S 0,5 atein

;leews Bisect -
S e ) sl wim b So sl 0l oe a5l sl eslasal b

Command: XLINE sy gosd (§]y2]
Specify a point or [Hor/Ver/Ang/Bisect/Offset]: p s Sl 435
SPECify angle Vertex point; aqly u*j) OO, At
Specify angle start point; = asly dlo sl 63, alais Sy 3,5 At
Specify angle end point; asl; c.La e (59, aladi S 0,5 ez

Start point

Vertex point

ol b slse o5 Offset

Command: XLINE Specify a point or [Hor/Ver/Ang/Bisect/Offset]: 0 «wweeeeess Silye (5 anS
Specify offset distance or [Through] <30.0000>:  -ooooovviiiiininivinennes Sile oS aols 5,5 o lg
Select a ||ne ObJeCt .............................................................................. 09».) LSS Q:;‘AA." )‘]é 45 ‘5C9..09A %JBLG‘
Spec|fy side to offset: o}w ﬁL?u‘ Lg.f S )‘)9 as N uo)f ua;v.w.a

P

¥fo



] 329 ¢ (oo y SoS ¢ oo i (5L ek JU o=y

el ""’LQ"LS' & C)‘ L;l.e‘;l.u‘ ‘;5 ORTTao Q‘ L;‘..\S.g‘ as
Ribbon :Home taby Draw panel » Ray
Menu :Draw » Ray '//‘ o ‘)}‘ k)"b 979 L;LQL)’"?) )‘ é" a )3:'”"& U"‘

= Command entry :ray

COMMANG: RAY  ceerrrrrrmeesssssssmssssssssssssssssssssssssssssssssssssssssssss s ssssssssssssssssssessssssssssssssssssees Lgwd gl -
SPECify Start POINt: e Eoyis alads 10 S aseie -V
Specify through point: e 5,35 oo o) 59, 5 g oo oSS oz a5 glakais oS asuie -Y
Specify through PoiNt: e G alady 10,5 aseie -

Start point

KWLy los SO dusles wwd ool 3l solaiwl b -

= TRACE )‘95 PO - M;‘-’uﬁ-")ﬁ-’ - 9-&5" )5*-“’" A ) ‘
JSiS aygly awlez oo ez (g (o8 do 4 jets o

Sg ol Cde g § )0 adall SO dliad s asii 1) s

Command: TRACE e :)9.‘1...,.,‘) 6‘)9‘ -\
SpeC|fy trace width <1.0000>:3 e L 6[...9{' QJ)S ua.‘?g.wo -y
Specify start POINt: (1) e (V) £gyi alais 820 -V
SPECIfY NEXE POINE: (2) e seeessssessese s esees s (V) o aais 3,0 ¥
Specify next point: (3) , S (F) o 4o 5 jue -0

5

Start point
4 3

R
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CIRCLE ol Sl b1y o plo ailes o ygiws ol 5l oolaswl b -
DS w5 ] calisee bl 51 ledlb|

Ribbon :Home taby> Draw panel » Center ,Radius
ool 2] BB 5220, slaghs) 5l (5o jgws

| )Ja_9 Diameter |

T

Menu :Draw » Circle

Toolbar :Draw I"r"":h
L

-.- Command entry :circle or ¢ T

oﬁ‘o C‘f)

Command; CIRCLE  crrmeesssssssseeessssssssnsesenens el aliwgds 0 1o o )i 1 jgiwd (gl =)
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: ... o pls 35 0 40,5 astine Y
Specify radius of circle or [Diameter] <1.0000>: 2 rrmrrssmrrssnresineens opls glads 0,5 5,9 Y
! Radig S E88 g gy Jle 4

2
Command: CIRCLE  cerereesssmeesssissesssssessssssssssssssssssees s aliwgds 0 1o s i 1 gt (gl =)
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: ... opls 35 0 30,5 azin -V

Specify radius of circle or [Diameter] <1.0000 >: D

il oS 0,28 g 48 4T sl eslatwl gl D ST ol -Y
Specify diameter of circle <2.0000>:4 5 Jake 5 o s ¥

O, du..».{ RS 959, JL..O 4 3k

Y



) 329 ¢ (oSS (oan 5 6L pole LU u=lg
o) bame (59, alais aw il bopls o i TP (Three Points) -
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: 3P

Specify first point on circle: (1) . opls Lo (59, alaii gl 40,5 atie Y
Specify second point on circle: (2)

Specify third point on circle: (3) 1

b SO g, wlo aladi aw ol aS 0uS dxgi o

3P
2P (Two Points) —
Aol cﬁb )Ja_‘)).w 9 A;J‘sssn alags 9 Q.,J ‘oﬁlo NEYEN &9 alags 93 Q.';..islo L oﬁlo o

Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: 2P ... YP s 5 olbsesl -
Specify first end point of circle s diameter: ... opls Jhad slakads (Jgl 0,5 asein -Y
Specify second end point of circle's diameter:

................. ay‘.)).’aﬂ‘s:l;bmué; S =Y

2

2P
TTR (Tangent ,Tangent ,Radius)

el SO g wlew 90 (blo bopls g

Specify center point for circle or [3P/2P/Ttr (tan tan radius)l: TTR ... TTR as ;5 Gl -\

Specify point on object for first tangent of circle: ... opls wlas oydgl 305 asein Y

Specify point on object for second tangent of circle: .. 0515 Lolon ymagd (33,8 aseiue —Y

Specify radius of circle <1.8000 >: 2 opls glads 0,5 5 )lg - F

1 Radius=2

Radius=2 1

tan tan radius
Yy
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Ribbon: Home taby> Draw panel 3 Tan ,Tan ,Tan 2979 ployp bz )0 0 pls e i S h9) 9z

S L0 ) 5009, e Sel S ey 00l
Menu: Draw » Circle » Tan ,Tan,Tan

TTT (Tangent, Tangent, TANGENE) s oobes dus ilo Lo o w3 -
D4 a5 010 0 LS el olows Loy | 5 0 1o 45 gad90 dw (59, ol (B a5 ) Sl L

2
1
1 : JL..a ke
3
2 3

Center
Radius
1 2
S gl
Center , Radius 2P (Two Points) 4k 52
3
Tangent
1 2
abii 4w gp (Three Points) TTR (Tangent ,Tangent ,Radius)

£
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ARC GleS e IS 5 OleS Sl oo Himd Sl eslaal L
Oleyp b 30 S e slaghy, 4o (92

Ribbon :Home taby» Draw panel 3 3-Point S Byb 5l et cpl el g o)l 979
Menu :Draw » Arc ooliinl (yloS pn 5 Ghgy 093k Sl 5 0S8 ‘)-'.’i:;‘

Toolbar :Draw f

= Command entry :Arc or a

;
(¥ g L=
Snet, Cinitind, DA

Sat, Covaes, agle:
s, Camtes, Langin

Lemt, End dngle

5wt End Domben
Samy, End Reden

Comvim, T, [
Gy, S, Sy

TAAS ATTR ARAD

oS Glasin -

E
£

;
4

Chord Length
bl akis End

oS 3, Center

o



Slosis b Lo i g o5 gil

COMMANG (ARG crreeeermsmieeesesssssssseessssssessssessssssssssasessssssssssssessssssssssssessssssssssnssssssees ObeS jews gl >l -)
Specify start point of arc or [Center]: e Ol Egypi aladi 0,5 jaseio =Y
Specify second point of arc or [Center/End]: - oS g aads 0 ST jastin -V
Specify end PoiNt Of @rC: e oS SLL ahis 0, asis . f

( Start' Center'End ) -
ObL 55y (g9 b alals Slaseiia (1Sl b (oS oo

OleS g9,% alali 3 5 aseie -)

ObeS 35 30 99,5 asine =Y
3 2 oS bl oS aseie Y
End 1

Center Start

( Start' Center ' Angle ) -
OleS g9y abai (0,5 azedis -

1 ObeS 3550 03,5 pasudee -V
Start oS agly 0,5 0)lg =Y

OleS aiS 3)ly (i 1) GleS sl ST
Center D9l g JoSLS uSe Zu 5o

( Start ' Center ' Length ) -
59 ok 55 e o, alali Slaseine (1Bl b GleS e 3
OleS g9,% alali (3 5 Azl -)
ObeS 35 30 9,5 asine =Y
OleS Sy Job 2,5 o)ls ¥
Length

Start

N

Center

s




o2k 515 9>y

( Start' End ' Angle ) -
42315 <0l < b 4l Dlasetin (18I b 0aS rms 5

Eoy alais 3,5 jasine =)
End v ! Sbb abis (50,5 Lasuive -V
’ Start OleS gl o5 )l ¥

( Start ' End 'Direction’) -
oy alais p oles Lo (L o8 abaki Slaseie 23 b Gl pen 5

30 R
S S (IR
/,(')'o

Sz Gess -V
End Start

( Start' End 'Radius ) -

el (Ll gy alads Olasein (il b LS s )3

QLJ&)&MQo;QM—\

2 o 1 Okl ahd (9,5 (asie =Y
<
®

Ol 4 gy 9 39800 S OleS Cuz WS S)lg wSen | (L g g9y0 abali gl > e ST

( Center ' Start 'End ) -

OS5 30 59,5 pasie -
; Eort ahail (13,5 jasie -V

g ol alais 55,8 asie Y

Start

Center
v
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( Center ' Start 'Angle )
gl (Eay Sy aladi Slaswine dlo b GlaS guw )i

S 550 525 )

2 OleS 58 53,5 At Y
. Start OleS asgly 0,5 o0,le =Y
1
Center

( Center ' Start 'Length ) -
59 Jsb g £9,8 5 e Slagin (Lol b (leS a3

3 OleS S0 (53,5 i -)
Length E OleS 9,8 alali (3 5 [aseie -V
>1</\Start 79 sk 0,5 olg =Y

Center

( Continue ) -
05 3y b g o9 ce Jog GLeS b a3 g5 5l o o 5 abas (3T 095 leS s (g cnl o
223 oo bl o> 5 4 gum abads
Command: _arc . .l 2
g oo ey 4l 90 b oleS (l @Bl 5o
Specify start point of arc or [Center]:

Specify end point of arc:

2
1 /2 1
End start Y End Start

Line or Pline or Arc

\ / S o5 5ied Cnl lage, Sl S bl e 5l S e

A
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PLINE S>> e ) Sty Ol b bt s g o Hews (pl 5leslaul b -
kS s Joy o2 @ izl () 45 05 sy oo e
Ribbon :Home taby Draw panel » Polyline slcwbes L Q‘53t5'° I b o pl wbl o

Menu :Draw » Polyline b j cles QBSLSA LS:}‘)“' J Q; o M
. g ol 1 o]
Toolbar :Draw ___ %

= Command entry :pline or pl

COMMAN: PLINE oo sssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssses g gl =)
S T e 11 A 21 0] 1| R ———— Jol alais 0 S jasie -Y
Current line-width is 0.0000  wswsssssssssssssssssssssssssssssssssssssssssssssssssssssssssssees ShFais Cubs 1 158 &l
Specify next point or [Arc/Halfwidth/Length/Undo/Width]: 4 - pgo ki 0,5 jasie -

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: 2 9~ aladi 0,5 jasie -¥
Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: 4 = -eeeeeeeeeeeeee o ke aladi -0

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: C
Lol alass g locul aads e 9 C 2SS 51 oolizwl L -#

. L=4 2 .
next point next point
-—

o\ o\
I * * I
— —

Close X_start point

4 —» 1 Arc —

Ol jeiwd (slaysild dan 0uS eolaiul 50 leS 5l edad a5 a0 j0 wlgl o 4y 3T ol 5l eslaial b
A5l glawas Lol 4o

Close —
Al albls dny datais SO ales o 43S ol 5l eslatll

Halfwidth —
DS asin |y s Culis aal 0lgs oo 4 S cpl 5l eolaiul
Specify starting half-width <2.5000>:3 ... AuS jasie £oyh a0 |y Sl aai )
Specify ending half-width <3.0000>: ... S aseie Gbl ahds o) cwlho aai -Y

- j: Halfwidth

4



e gl 5 055 S

Length —
S8 ol b Job 4 (L8 b 5wl e b e 5 0o 5 a5 Gl sl ool L

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: L ... Job 435 5l eolazul

Specify length of IN€: 20 s aS ole 1y das Job o adlsl jlade

/’/
1 2 Undo —

28,5 5l e 4y Al e S als oo 43Sl Sl oslaal b

Width —
WSS 0lg 1y b culs S ailgs oo a5l 5l eslal b

Specify next point or [Arc/Halfwidth/Length/Undo/Width]: W _.ooooooe..... Ly 43S 5l oolaul
Specify starting width <1.0000>: 3 il e Sslite wa b bl 5 £grd 5o b s Jlie cpl 4o
Specify ending width <3.0000>: 8

Starting width = 3 i ‘ :]:E”ding width = 8

Specify starting width <3.0000>: 8 el sl il 5 oy Al s L caali e ol o

Specify ending width <8.0000>: 8

Specify starting width <8.0000>: 0 alais 5 5 yho £oyd alas o b Cuslis e ol o
Specify ending width <8.0000>: 8 bl se St SLLG

ol oad pg e S LSas el b i Jlie oy

Starting width = 0 < :]:Ending width = 8

Do
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RECTANGLE ax LS Jibies & b dhins alg go jeiws (pl 5l eolasal b
S o 5 Az LSS

Ribbon :Home tab» Draw panel » Rectangle

Cwlylo 1) o Jadaiz cools gy o)
Menu :Draw » Rectangle ’

Toolbar :Draw E

cm 3
o Command entry :Rectangle or rec

Command: RECTANG s ssssssssssssssssssssssssssssssssssssssssssssssssssssssssns Hgewd gl =)

Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]:
o,z adsS gl (9,5 ateie Y
Specify other corner point or [Area/Dimensions/Rotation]: @70,30
ol 00l oolainl s g, 3l ] jo (pgd dlgS 0,5 asuine -Y

2/ @70,30

o
M

First corner

70

—4—

——

Area
S 5 E5ose crbas (55,8 85 b el 45l 1) ako Loz ol Lo aS e a3 ol 5 oolial L
D9l oo o (o2 ez e ]

Specify other corner point or [Area/Dimensions/Rotation]: A ... Colune 435 olasl -)

Enter area of rectangle in current units <230.0000>: 120
ool AdST 10 188 g Coluce (0,5 o)lg Y
Calculate rectangle dimensions based on [Length/Width] <Length>: L
Ao Slas ) ol adS awm g ]y oye b aaS o)lg 1) b aales o auS asein -V
Enter rectangle length <22.0000>: 10 e AS 8lg |y Jsb Jlade -F

S=120m’
1
10

First corner

O



Sl slaaiils 5 o5l P
Dimensions —
S bl IS cam calyd 10 g 00uwp alBlax 1) oy g Job ade wSgl an S ol 5l ool b

Specify other corner point or [Area/Dimensions/Rotation]: D ... Lo 31l ass 35 el - )
Specify length for rectangles <20.0000>: 22 v Jsb Jlade 50,5 o,lg -Y

Specify width for rectangles <15.0000>: 16 e 2 lade 0,8 5 lg =Y

Specify other corner point or [Area/Dimensions/Rotation]:
MSWLNQ&AJPL‘)GA@)LQ}MP—\C

£
To
= 1
First corner
22
length
Rotation -
Ot asly b (ldlez b o B oS o)ls ) (b 2552 jlade wilgs e S cnl sl eslaul b
Sg o i 00D
Specify other corner point or [Area/Dimensions/Rotation]: R ... LSy a5 ol -
Specify rotation angle or [Pick points] <0>: 45 s agly Jlade 43,5 o)lg =Y
Specify other corner point or [Area/Dimensions/Rotation]: oo Jgl &S 18,5 Laseine =Y
Command: SpGley Opposite COMNEL: coeerecesermsommamsinnsstssimmetssamssssuasstssassssssassssssass £y M; uo; 9)15 -f

First corner

oY
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Chamfer —
3l & s O slaaiss a5 w3 ol ez il a3 Cal 5l eslial L

Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: C a3 ol -
Specify first chamfer distance for rectangles <56.0000>: 8 ... Zo alold gl 0,5 o)l =Y

Specify second chamfer distance for rectangles <5.0000>: 8 & alols ego (0,5 o)ls =Y
8

‘_\ First Distance

OOT Second Distance

Fillet —
Aol alils o5 sledaisS a5 auS e i 2o i ».\.u‘s.:‘sc ‘&L’..is Sade pudaid g a5 ol 5l eolaial b

Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: F an;S ol -)

Specify fillet radius for rectangles <8.0000>: ... absS 5,5 el Jade 0,5 5 )ls =Y

=)
Fillet Radius

Width —
IS e S |y (o lez bglas ailgh o a5 cpl 5l eolaul L

Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: W 435 <bxsl -

Specify line width for rectangles <0.0000>: 2 s bl jlade 0,5 o415 -Y
v%idtt_h WOls )5y adgl cdl> |, YU sloass 555 slopadais a5 Slej U rasgis
1 .

oY
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: ‘ ; Poligons ol 5 eslaal L

POLYGON phie alodis o u’| 5 -k
Ol Pog=°

Ribbon :Home taby Draw panel » Polygon /\ )'| ‘5"L°g5’J“‘““'>
VoVF b oo ¥

Menu :Draw » Polygon

. 255 o s
Toolbar :Draw |

= Command entry :Polygon or pol

CoOMMEANT: POLYGON  coeeeerrrmessissesssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssessssss g gl -
Enter number of sides <4>: 6 -sues )Lid |, sl oS g oS jasin |, aloois edol sloas -¥
Specify center of polygon or [Edge]:  -eeerrrrreemsssssssisississsveeeeee S atin |y aloais S e =Y
Enter an option [Inscribed in circle/Circumscribed about circle] <I>: |

(Dgd o0 2,8 opld 1o blxe alodiz iy, (pl jo) ( dblxe g, ol -F
SpecCify radius Of CIFCIE: 8 wereeereeeeeeeeeeeeeeeeseeeesseeesesssssssssssssssssssssssssssssssssssssssssssssssssens opls gl 0,5 54l9 -0

*

X X X e

Radius Radius
Inscribed in circle Circumscribed about circle +

Enter an option [Inscribed in circ]e/Circumscribed about cirgle] <|>'c . '
(09.“6,4; 0)‘,"0 x Ja'“'?u G*J"éw P9 u" )5) ‘(;IG-A-?-A,, P9 ubu..,‘ -¥

Specify radius Of CIrCIE: 8 ... opls glads (50,5 0,15 -0
i Edge —
23S e Ol e sk Gosbo I (rldaiz adlgie 43S ol sl eolizul b
Specify center of polygon or [EAGe]: E v o 4§ bl -)
Specify first endpoint of 8dge: ... ahats gl 0,5 aseie Y
Specify second endpoint of edge: 16 occcrrricrrccerrrisreececerenieees Sbb aadi 0 5 5 ls -V
First Point =T Second Point

Of
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Revision Cloud et 2P g al sleolitall
sk 979 4 gasibe pl S5
Ribbon :Home taby Draw panel » Revision Cloud )L‘-’ (S i UL’L‘-@}’ 4 as
Menu :Draw » Revision Cloud 'b)"b
Toolbar :Draw i .
= Command entry :revcloud
COMMANA: FEVCIOUM  wrrerrerrrereereeresnssnsersessssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssses g gl =)

Minimum arc length: 0.5000 Maximum arc length: 0.5000 Style: Normal
5l lapelass 1 Go)1iS sl =Y

Specify start point or [Arc length/Object/Style] <Object>:  .......... Egym aladi 10,5 asuie -V
Guide crosshairs along cloud path... .. Dgd on dloul gl plazas (o LS oS > L -
Revision cloud finished. ... Do oo s g 0 S ol ¢ Jol adads 4y Lad) o 90,5 Soo 3 L -0
/‘\/‘f/‘ (s glgS Joe
Style =Normal ~ Style =Calligraphy
Srexe J ~ ~ Arc Length —

DS ez |y o pleS Job jiSTas g JBlas ales o a0 35 ol 5l ool b

Specify start point or [Arc length/Object/Style] <Object>:a . oS Job a8 bl -)
Specify minimum length of arc <5.0000>: 8  -wrerrsrrsmrsessnnee oS Job J8las 0,5 0,lg =Y
Specify maximum length of arc <8.0000>; 12 wrwrsrrrririrrie oS Jsb jiSTas 50,5 o )lg Y
Object —

S R il Rl ]y az LSS slaggdge wilgi oo 35 cnl 5l eslaul b

Specify start point or [Arc length/Object/Style] <Object>: 0 ... Eaog0 aiy S bl )
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Copy  lagssse jl sl asus b S 5550 5l aud 2z b i;i? )i:,o ﬁj
o = )0 -

Ribbon :Home tab» Modify panel > Copy
Menu :Modify » Copy w‘ ‘P‘ J.tlﬁ 9)4"5) GL‘”u’"ﬁ) )‘ L;" b )9:"“") L)"‘
Toolbar :Modify ':-f',;

Shortcut menu :Select the objects to copy ,
and right-click in the drawing area .
Click Copy Selection.

Command entry :copy or co

COMMEANd: COPY  commsssemmsssmsssssssssssmsssssssssssssssssssssssssisssssss s s sssss gewd gl =)
Select objects : 1 found s (Egog0 bl Globs,) bEgoge b ggoge wlswl -Y
SElECt ODJECES i ooveeeececeieveveisssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssnnes sl oS 0,8 L el ML: _y
Current settings : Copy mode = Multiple s oS g it 5l 1S &)

Specify base point or [Displacement/ mOde] < Displacement>:

S o sl (lgreas abais S Ol Y

Specify second point or <use first point as displacement >:

S 7o ahts flgiedas pgo alais CLsl -0

Specify second point or [Exit/Undo] < Exit >:

5 95550 oy b 2 poo ala g w3gumel (5 (S 23l o0 Mulltiple 4 S s (53 05z
DS s o ahts lgieas | g0l slaalass ailyr oo Lo

base point
4 o
2
2

Mode -
b ogd oo el anyS opl ol
0055 (oS Ry 9SSl L
gamal b ail SO

(Al
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Move laggoge (15,5 ral> Sl Glaggoge b gad5e iilyi oo j5ims I L
S Ll g 5 amio ) |, a0l

Ribbon :Home tab » Modify panel » Move
T ——— el 12l BB g g5 slashe, 51 S b ygims
Toolbar :Modify —E-.-

Shortcut menu :Select the objects to move ,
and right-click in the drawing area .
Click Move.

Command entry :move or m

Command: MOVE vttt ettt )G LS‘)" -\
Select ObJeCtS 1 found ................................ (&9@5.0 AT)l?L;.J" Glﬁwa)) lﬁws& l% 69.&5.& ;'Al?c.u" —Y
SEIECt ODJECES : ot Sl oS 0,28 b el b ol al -

Specify base point or [Displacement | < Displacement>:
s sl lyea abis S Sl -F

Specify second point or <use first point as displacement >:
Qaie aadi lgieds pgo alats Ol -0

base point

Yo
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MIRROR slanl g sl 5 ble wrle wile plaglasle wis o
5590 Caamd aiy B laisle 5l ced a5 los

Ribbon :Home tab » Modify panel » Mirror 2,5 oolaiwl jaiws cpl 5l les o il o
Menu :Modify » Mirror )
Toolbar Modity /]l 2l Glhas jyiwd cnl jo CoS anl lgd

Command entry :mirror or mi

Command MIRROR .................................................................................................................... 1)9:».».00 6‘)?‘ —\
Select objects 1 1 fouNd e lggoge b goog0 ool =Y
SeleCt ODJECES & v il oS 0,8 b ol ML -y
Specify first point of Mirror iNe: e anl s sl adads fpdgl 0,5 asin -
Specify second point of mirror line: ..l anl sl adas fpegs 43,5 Lasuie -0
Erase source objects ? [Yes/ No] <N>: S o i

4X sl ods o i8 g 5 S b osd Bi> Lol gaog0 LI -F

i —_— = =
2_| —>
5

Erase source objects ? [ Yes/No] <Y>: ) N -

4 Fsl oS o jid g ali S Loogd Bds Lol g4090 LIV

:Z/Zl/m H\:
5 —— | I
Command: Mirrtext ..o lodiig oo aisl 390 10 ol yuiio
EI'IIZEFITE‘H W[UB fﬂr' MIEHTEH {ﬂ}: QI ooersoeeeees e A.wl.s‘sn sSJ 9 )M dde 5& O ).u.?.o u.s‘
R3 R3 R3
+12V  12V+ o +12V
10k 10k 10k
MIRROR ! & MIRROR ! o= MIRROR ! o=
MIRRTEXT = 1 MIRRTEXT = O

\id
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ROTATE laggoge (i, b oly90 Sl slaggoge duiles oo jgiws (ol 5l oolaiul b
Ao oles alads G j0 |y ool

Ribbon :Home tab » Modify panel » Rotate

Menu :Modify » Rotate JB g,y sloss, 5l ol eslaul b g ()l
Db o 1y
Toolbar :Modify O et T

Shortcut menu :Select the objects to rotate ,
and right-click in the drawing area .Click Rotate.

Command entry :rotate or ro

Command: ROTATE s )G LS‘)'." -\

Current positive angle in UCS : ANGDIR = counterclockwise ANGBASE =0 )
O9d &30 9 090 Lz 9,90 50 (5,155 &l

Select objects : Specify opposite corner : 1 found legoge b gaoge ool -¥

SEIECE ODJECES | vttt sl alS 0,28 b Sl al -

Specify base PoiNt s 3190 35 pe Hlgreas alnds SO Slesl -f

Specify rotation angle or [Copy/ Reference] <0>:90 e e asgly 9,5 8 )ls -0
</ </

base point

ANGDIR = counterclockwise ANGBASE =0
Cote Zelo slaayie D Gligs Cuzr ¢ oligs asly £9,5 @z

s poss Unit jgiws g,k 5l b g Command & ,b 5l oslgs oo |y jexie 98 0l

Yy
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Copy —
Aapd ol g0, u,J,‘al J PARE Mly‘sfa ainyS ool 5leslaiwl b

Specify rotation angle or [Copy/Reference] <0 >: C Rotating a copy of the

selected objects. ol bl 9090 5l oS SG g0
Specify rotation ang|e or [Copy/Reference] <K2T70>1 s Q‘)S’) Qg‘j Qo; o)|9

2 — > \ / - s
4 base point

5X

Reference —
Db ooy sl ple laggdge ()90 a0 i sl 43S 0l
Command: ROTATE ............................................................................................................ :)9:.».00) ‘5‘)?‘ _\

Current positive angle in UCS: ANGDIR=counterclockwise ANGBASE=0 _
5 Ol sl e 51 (3155 )|

Select ObJECtS: 1 fOUNT s Sao90 ol =Y
SEIECH ODJECES: s Sl alST 0,28 b Sl al -
SPeECify DASE POINE: oo s 3 e bl =¥
Specify rotation angle or [Copy/Reference] <O0>: R v, B o S A8 bl -0
Specify the reference angle <0>: s Olygs 35 e 0 bgs bl -#
Specify second point: e (oL Y o # ahats o Wilgs o alads cpl) pgo alnds Ol -V
Specify the new angle or [Points] <0>: 0 e Olygs agly 0,5 o,ls -A
2
7 —

base point © 4 base point

Points —
S oolaiwl 4 64, alive adadi g0 5l 190 asgly 50,5 0l sloay wlgl ge 43T ol 5l eolaiul b

YA
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OFFSET il oS obl ! EPee Sl e st ol Sl eslal L
S s Sl S

D)l g0l 08 M ey Gl s )
ool asle oo g9, o g, 3l So 5l eslal
DS Tl giws

a2 90010 0550 50 jgws (plaS Cal SS @ eV
Command entry :offset or o "))‘;\fcs‘ )_’| QT él'”*’ $9)

Ribbon :Home tab » Modify panel » Offset
Menu :Modify » Offset

Toolbar :Modify -{_]3_

ComMmMAaNnd: OFESET  cerrrereeessssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssns fgiwd (gl -

Current settings: Erase source=No Layer=Source OFFSETGAPTYPE =0

5 cnl slaedas 5l )15 4l
Specify offset distance or [Through/Erase/Layer] <Through>: 2
Eyoye (o5 abols (3,5 5l Y
Select object to offset or [Exit/lUndo] <Exit>:
(b oo Single g, 5l s jgiws cpl j0 Ol oS Cbkl ) ggoge o > ol jo Y
Specify point on side to offset or [Exit/Multiple/Undo] <Exit>:
AS S 05 oS Ea0g0 dudler 0 dS e b Cg> o Wb Al e ol o -F
Select object to offset or [Exit/Undo] <Exit>:
S Bl (595 (oS Sz |y oedee 95l 0 0 )kgs O
Through —
S Gl g g ge Dlads b Ll a2 o 03l alold Canslgz o ygus el oo jud (2,8 i 4S 43Syl
Erase —
> b ogh Bds Lol gadge cad (o5 5l aw aF sy oo Lol a5l
Layer
Behee 2 p; by ansS al Gzl o
Enter layer option for offset objects [Current/Source] <Current>:
Current —
255 I8 Gl Y jo eal oS £adge 09d o0 Eel 4T
Source —
S o] Lol gaoge Y J0 0l LS £abge g o Cuel 43T oyl
Multiple —
adgl ooy cpns alols lea L], Lol g0 sl oS gt slaSCIS U ailes co 438 ol 5l oolazwl b

///K:\x\
- .
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STRETCH lggoge (Sois P 1y lgsdse ailg oo jaiws nl 5l ool L
DS 00,08 b 0ty sl o 45 S
Ribbon :Home tab » Modify panel » Stretch
Menu :Modify » Stretch

Toolbar :Modify E

Command entry :stretch or s

Command: STRETCH  rrereeeerrersssssssssmmsssssssssssssesssssssssssssssssssssssssssssssssssssssssssssssssssee fgewd gl =)

Select objects to stretch by crossing-window or crossing-polygon...
2L oo Crossing-window or Crossing — Polygon jgiws oyl jo ggo90 ol ol Lo

Select objects: Specify opposite corner: 1 found .o, Eaog0 oLl =Y
Select objects; ....................................................................... )MJ KWLy Qo)&é )‘| oolaiul L ol M‘L ol
Specify base point or [Displacement] <Displacement>: ... b alai 0,5 jasin -F

Specify second point or <use first point as displacement>: 6
el o0 45T Sz )0 Jsb 50,5 9)ls b pgs alal 0 ST etk -0

crossing -window or crossing-polygon

2 4

| |

[ [ Q| g (g | I

—» L=6 . ><1

base point

&S oo Joe MOVe jgiws Jolae jaiws ol 0,8 )18 Gl o,y (9,0 laggdge dnn ST jgiws ol jo

Ao
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ARRAY oz Qlj‘_il z° e b oS asle o Hetws pl 5l eolaiul
S ol (Glheo by (Sow 9 sl )90n
Ribbon :Home tab » Modify panel » Array RPWs 3L e IS d;Ua.o 6o (jgws 6‘)_?'| L

Menu :Modify » Aray ib oo Polar gRectangular as ;5 g0 Jolis a5

Toolbar :Modify HH

Command entry :array or ar

CommaNnd: ARRAY et ssmsssssssssssssssssssssssssssssssssssss s gawd (gl >

Rectangular Array (Sgww 3 Sl & jgod oo

65.00 EJ
20.00

By defanult, il the now off sl is negative,
rows are sdded downmwand, I the

oy, alold

Row offset
110

2

B

)
)

S

lil QLQ%_? ‘%I} Angle of array

Column offset (g alolé

i

AN



3 oleduz dugly g9 baygiw g oo, alold 0,5 o)ls sloas ailed oo aeSs (! 5l eolazul b 1
AS Ol b clilo p ands g9, 3l agly b alold lea b blas g a8 5 S wglo

PR TR ] IR FRUPNWP TR PRVESRVEL SO PR SURCR RE CRLIIVY U J VY FRONPT L R DWW Y
D on JoSis o Caomnds loduz AiS olg ke dae | b ygiw alold 31

Argle of amay:

®

bS.0000

By cafiault, i the v offesd s nagative,
i ot DU, Dok

i magEiive, am
added to the leht

©

i 260 — 260
Emﬁmﬁ
| | |
& IF1 Fi F1
. %M%Flﬁ
a | ‘ F1
F1 Fi |
- F1 Fl
[ ]
| opemtangh oy

(Se:1/100)

oS 959, Ogewliod O 4
e e SowS
Oledez )0 jgiws cnl o8

AY



Olysd Sy 9,5 Latiae
Coterpoint- X 0520000 Yy 31.0000 m
Miethod and values -

Method: Ol,55 %)
| Total number of Eema & Angle to il 'fl

T:lim.ntqrﬂéw- 8
hﬂhmﬁ%y 360 ﬁi]

SUTT T
(CIEEN 520D
Angie betwsbn fams: o
loggog0 (2 429l5
(1) Forangletofil, a postive vakue specifies : :
oountsinciowise rotation. A negative value b (o,

Tg Pechies clockwise mlation
: o[

[ More ¥ Olod e Pirioyany
| Fiotale hems a5 copied | =

[

S 0S ol blie Db 4
[ easz sges 2L Mk cnl ey Gl
S deo sy dapgie a1 (ka8 O jg0n
S O'l‘ )| solaiwl b don l.cb(_,,JM 9 Lboj-';-w)w
Ll 00 (ot S ygiansd
/1y \\
Sy L I AT
L Tm—=dbk=——""
L

GROUND FLOOR PLAN

AY



For anght 10 fill, & posteve value spaciios
counianmiociowise roistion. A negative value

+ Rotste bems a5 copied 3

Total Number of Items

loggoge slowi (40,5 5]y b,

Angle to Fill

(655 yo alai 590 ool Sl slaggoge (4590 argly 0,5 0)ly b, | 1
Angle Between Items

E3o30 99 (e dagly 50,5 3,1y (b,

Sas (53,5 3)ls g 05b 0 el slaayydie IS (590 el aygly sol> Cude dae (0 S 015 | 5
g Selo ladyyie Cu 0 laggdge 132 cel (pledaz gly sl ke

Rotate Items as Copied | 3
03ls 0ly90 G 635y abali 93 ledemr Glojy 4o end Sl gedge aniS (nl pad JLs L
e 2Bl Jbd e 515 090 0

i E Jlsé Rotate Jus . Rotate

AY
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SCALE R - Sl slaggoge auiles oo jgiws (pl 5leolaiul b
S S5l S eS bggdge ;K00 4y S | 00
Ribbon :Home tab » Modify panel » Scale 09,...;‘5@ 1)_?1 929, dlﬁui’j) ).| é-‘ b 5w Q—.’.‘

Menu :Modify » Scale
. e |
Toolbar :Modify DJ

Shortcut menu :Select the objects to scale ,
and right-click in the drawing area .Click Scale.

Command entry :scale or sc

COMMANG: SCALE e smsssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssee g gl - )
Select ODJECtS: 1 FOUNT s loggoge b ggog0 ol =¥
SEIECE ODJECES: ottt Sl 0S8 b beobesl ol -
SPECIfy DASE POINt;  wwrrsmssmssmssmssssssssssssssssssssssssssssss s biw abads 0,5 adein ¥

(Ngd oo S5 g SgS abaii ()] 4 G laggoge plas a5 (slabais)
Specify scale factor or [Copy/Reference] <1.0000>: 2

(35 o0 50 Sy adgl g9b90 (B B Dot WS G) ulide upo (59,5 9,l9 -0

ﬂ —> 2
base point> y

Specify scale factor or [Copy/Reference] <2.0000>; C  wwrwersemssesssssssese S A bl

Scaling a copy of the selected objects .
D9 o D02 oliie b g9:550 o 51 (o5 5 wiley ol sl £5.050 b 05 co el 43S ol Sl

2

ya
base point I

AD
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Reference —

COMMANG: SCALE  eeerreeermismeeesmimnecsssssmessssssneesssssssesssssssmssssssmsesssssssessssssnessssssnessssssnssssssons g gl =)
7= 1201 A0 o)1= (=TI {0 10 o [ lggoge b goog0 ool =Y
SEIECE ODJECES: s Sl 0l o886 b ol anb -y
SPECIfY DASE POINt; o (SAS) Lo alaiis 10,5 aseie -
Specify scale factor or [Copy/Reference] <1.5000>: R e & o S aig S ol -0
Specify reference length <1.0000>: 1/100  ccovermsicerssiserssiienns 28 wlae b Job 10 S 0 )lg-F
Specify new length or [Points] <1.0000>: 1/50 «eeeerreeesssnnenen el olde b Job 0,5 5l =Y

base point ||

OED

oM

§C:1/100

SC:1/50 Points —
Sy SeS Al (g5, ahad 9o 5l ales lide b sk (59,5 9)ly sl wsilg e 43S cnl Sl ool b

aile 6 mS b s liel slacl 51 ol oo (Jg ausS colainl caie sae 3l aley cad wlhide jews (o iaxgit

S oslitl YU Jlie
b s 1S5S Al gadge 4 Cand Jool> JSE 03l 5SS V5l 58 b (s Liel sue By -

AF
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TRIM i< @ S loggdge oy 395 ol g 9590 Wuilel co ygiws ol sloslaiwl b
DS aad e S A Cad )

Ribbon :Home tab » Modify panel » Trim B g9, la g, 31 (SO 5l eolaiwl b giws oyl
Menu :Modify » Trim wob oo 12l

Toolbar :Modify .-J.n'.-_

Command entry :trim or tr
CommaNd: TRIM e ssssssssss s sssssssssssssssssssesssssssss JYVORREPJEH B

Current settings: Projection=UCS, Edge=None s~ (2l ool nulais slo it 51 3,155 &1 |

Select cutting €dges ... s0 2Bl 8,90 40 WSl sy
Select objects or <select all>: 1 found s ON e ol =Y
SEIECE ODJECES: oo Sl ol e 28 b ol an b -
Select object to trim or shift-select to extend or Dgd Bl aublys o a5 ted bl -F

[Fence/Crossing/Project/Edge/eRase/Undo]: ’ 2’ ’

l i Crossing

Crossing

)

AY



Slosis b Lo i g o5 gil

[Fence/Crossing/Project/Edge/eRase/Undo]: f ..o ool Feileczcijfgbwl
Specify first fence PoiNt: e ssessiaanns 00, 3l akads gl 08 e
Specify next fence point or [UNdo]: o (pgo ahad)) (gawy aadi 10,5 jastiv
Specify next fence point or [UNdo]: e (pyw abai) o alaili 15 S Azl

>4< >< Fence

X

Project —
Al doles 00ls sl (gum dw ol o

Edge —
Al aeles ol g el 43S ol 5leslawl b
[Fence/Crossing/Project/Edge/eRase/Undo]: e O e SeeSe ol

Enter an implied edge extension mode [Extend/No extend] <No extend>:

. Extend —
Al aslo ébl.@.* gy bl o> Gglpw’ | £ gS90 ;s Q.l‘ ol b
No extend —
eRase —
DS SU 1) cilisee slaggoge b gaoge duilys oo joimws Gl Gloy ,o asS ol bl b

[Fence/Crossing/Project/Edge/eRase/Undo]: r

Select objects to erase or <exit>: 1 found ) _
Trim Sy gl las ST as g
dod oo Hlad | ol alds LS

— _B_ — R — — —_—
—» T E‘J > T g o PamIte (i e dxho (49,0 Saggdge

erase

AN
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EXTEND ro < b goipn 4 i, 2275 €9250 e s5iod Gl jleslinl -
S5l 4 baio awps ool ales o a5 (65,0 U
Ribbon :Home tab . Modify panel 3, Extend E3050 Jawss 5l o) Cuz 4 gadge Sl e

Bad plol Gl ) e Comods
Menu :Modify y, Extend F Rl e BE i

Vel Tl oty S yuio Extend o Trim jgiws (glogulass :asgis
Command entry :extend or ex il oo alin g
CommaNnd: EXTEND i yghwd Ls‘)"’" -\

Current settings: Projection=UCS, Edge=None  ,guwo (2l ool pdais slo punito 51 5,155 &1

Select boundary €dges ... s 3% ol 90 4O .,\59.3" Toog
Select objects or <select all>: 1 fOUNG o Oy a0 o=l =Y
Select ODJECES: e s ol adS” o s b o] ..\.._:L =Y

Select object to extend or shift-select to trim or ey j 0 4 aples 0 a5 codg0 ol -f
a5 b 1) Shift oS > cpl jo 31 .08 solitul sad S ggog0 bl slael, oles 51 alys oo
[Fence/Crossing/Project/Edge/Undo]: Sy e TTM & Jos jgiws ol agls

____________________ FH- —
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BREAK Oy Iy 2Bl ggoge auily co jgiws (pl 5l eolanul b
AlBlax ggog0 90 4 g 0iSiy alall g0 b SO
Ribbon :Home tab » Modify panel » Break A_._.S J_.M

Menu :Modify . Break

Toolbar :Modify

Command entry :break or br

COMMEANG: BREAK ~ rreeeeeesseseesssessessssess s s s 5858858 Hgiwd gl
Select ObJect : i (S5 oo Cgme CanSlls gl alaii calads pl) fadge bl )
Specify second break point or [First point]: e CanSls pgo alads Gl -Y
1 2
N - -

Specify second break point or [First point]: f First Point —
S Ol 6,bg 1, gl abais cogga el i3 ol ol

Specify first break point: oo ConSlsy adady oyl Gl -)
Specify second break point: s ConSlls adadl pogs ol -Y
2 1

- // 7% \ - // 7 \ \

\ yﬂ — \ yﬂ —

/ /
N~ N
Break at Point [ oy G0 S ol

Command: _break Select object:
Specify second break point or [First point]: _f
Specify first break point:

Specify second break point: @
1 2

Q0
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JOIN Silwaz LS ) gsoge 2z b 9o alys oo j5ims cal jleslial b
Loggose 4SSl by ay i az LSy 5 Jato o2 &y
Ribbon :Home tab » Modify panel » Join ML u)f )‘)5 l.lwl) &’ I

Menu :Modify 3. Join

Toolbar :Modify —f#—

Command entry :jion or j

CommMaAaNd: JOIN ettt ygmd 6‘)9-‘—\
Select source object: ........................................................................................................ Jﬁ‘ Ego90 ol =Y
Select lines to join to source: 1 found @ e P9 Epo90 ol =Y

Select lines to join to source: w5 bl ol oo il S9g0 o8 (6,508 ggo90 STl 10 (pl )0

11lin€ JOINE 10 SOUIMCE oo ssssssssssssssss s sssssssssssssssss s Golw az LSS 5,158
1 2
B ———B——
1 2
——a- —E—-
CommandJolN .......................................................................................................................... :)9.1“:‘) LS‘P‘_\
Select source Object ....................................................................................................... QLQS AS.) b’)w‘ —Y
Select arcs to join to source or [CLOSG]Z L e oﬁb uS.a O uLQS ud..w J.n.\.u -y
Arc converted to a circle.
LB
: I
//
CommMaAaNd: JOIN e e Y VOV Lg|):.>\—\
Select source ObJeCt ............................................................................................... ‘saa.u uLQS ASJ ul?v.u‘ —Y

Select elliptical arcs to join to source or [cLose]: L
Ellipse successfully closed. JU e SO pan S ul oS =Y

/El,__
4
=

)
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CHAMFER zo ol aS L g0 o led co Hetws ol 5l eolal L
PSS S99 slalold o by g ules S akad | 508
Ribbon :Home tab » Modify panel » Chamfer IRVES I E 9| r TS VIPRVEL g S SU R

Menu :Modify 3. Chamfer

Toolbar :Modify Ie-’"

Command entry :chamfer or cha

COmMMANd: CHAMEER  ceeerrmssssssssssssssssssssssssisssssssssssssssssssssssssssssssssssssssssssssssssssssssssss Hgewd gl =)

(TRIM mode) Current chamfer Dist1 = 150.0000, Dist2 = 100.0000
o5 Ol sl e ) 3155 |
Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple]:
L | als sl Gl -Y
Select second line or shift-select to apply corner: ..., b | als pregs Sl -Y
first line

1

=

150
—
- 3
second line | 2 -
0 —Pp
Distance —

DS et |y 90 g Jol ald (59, alold wile o0 4S5 ol 5l eolazl L
Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple]: d

Specify first chamfer distance <15.0000>: 100 «eererreeesssseneeenees Js &o g9, aols o S 3,lg
Specify second chamfer distance <150.0000>:; 100 -wreeeseesse 9o o (59, abols (10 5 )l
,1_| 100 ,1_| 120
1 2 \I ] 2
—> —>
Polyline —

S Jloel loaissS aan (53, |, ¢ 9l o0 2l 42 LSs Lo £5050 45 590 50 4 (nl  eslizal L
Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple]: P

Select 2D PolYliNg: s 4:>)l..5.a Ego90 ol
4 lines were chamfered .. Jgiwd 0 Slae 51 o 138 sl

Rectangle >

¥
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Angle
DS Sl 1) sl w4y S pgs wls aygly 5 @ho S Jsb wiliooe an S cnl 5 ool L
Command: CHAMFER S5md ol slapaais 31 3,158 @l

(TRIM mode) Current chamfer Length = 15.0Q00, Angle = 30

Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple]: a a4l (bg, bl
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