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Ribbon :View tab » Navigate panel » Pan
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Menu :View » Pan » Realtime
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Press ESC or ENTER to exit ,or right-click to display shortcut menu.
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REDRAW Sz (yled
Menu: View » Redraw
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B Command entry :redraw or r
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befor Redraw

59909 ,o Refresh jgrws Joles jgrws ol
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BLIPMODE

= Command entry :blipmode

Command: BLIPMODE

Enter mode [ON/OFF] <ON>: OFF

after Redraw

S9) SUs ):‘ aS dliwd ‘5&.;5& + 6[.&:;’44,)19

ICEX olid |y axans

e 1,z

Pl L a3, ke (0] 45 S aieie
Yy



Oinles dzian S 00 s o 5 Azl

REGEN S (oo 39 95290 (Spam § oled jgiws ol 5l eslaal b
Ngd o i 0)lgd gl dxbo

Menu: View » Regen

E®  Ccommand entry iregen or re

ons ISh a4 g ool )5 095 Lol S 5l ol b leS aile Slgo slagasge gdlse 51 sl o
Sy |y Fill st piio J1 qudlysey 51058 Gyl y |, i ol Wil oo Regen jgiws ol o o
S 12l LS 1, Regen jews wib pien n95 sbogsge

befor Regen after Regen
FILL (o yiia 4SO 1 el gamgd loggdse 69{)’*‘“’ o
— . S o5 098 b JB e 1y T Wil oo
-Command entry fill
Command: fill S5 gl =)
Enter mode [ON/OFF] <ON>: off Uhsels b ol (g, paiie ol 9uS asedie -Y

QS eolanwl Regen jgiws 5l pxie opl s 5l o laggoge 59, Fill 51 s 1y
S, o,Lil iy oylae 4 lgi o o ygiws ol ales )
2d solid, donut, Pline, Trace

Pline Pline

FILL = ON FILL = OFF
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Zoom Extents (o Regen (¢ Zoom All (o Explode (.l
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LINE le ol o peebaZo)ly oyl o cnl 5l eslaal b -
3959 Sl by 4ed l aly o ) nl slp oS

Ribbon :Home tab»- Draw panel » Line e el labais ol

Menu :Draw » Line

Toolbar :Draw /

= Command entry :line or |

el Lyl BB 9,409, slo o, 5l (S 4 j90ms ol

COMMEAND: LINE coerreeeeemmrerseeesssssssesseeesssssssssssssesssssssssssssessssssssessssssssssssssssssesssssssssssssssssseces s (gl )
Specify first point: oo (Sl 00l SIS gl byl o p0d 40 ) S aseiio |y ol alads -Y
Specify next point or [Undo]: 4 e (pgo alaii) .auS astive | son alads -Y
Specify next point or [Undo]: 3 e (pgw aadl) WuS jasive |, gox aki -¥
Specify next point or [Close/Undo]: 4 ... (ool ahai) S asin|) gow ahii -0

Specify next point or [Close/Undo]: ¢
adats 4 alads 1,31 ol oS 0,88 g leyd b 0 C B> ol g Close jgiws 5l soliul b ¢
gl se @ s 5l il alS (50,88 L & jgoinl 28 )3 5 e pled jgiws 5 ode )

next point L=4 3next point
< el 0o soliwl O1tho lpl 51 IS cpl s 5 50 -

™ ™
I 1
— + * —

Close 5 — 5

1 L=4 next point

start point

S a5 03,5 iy sative bl 59, LipSe 095 e el : Snap = F4

oS o bl gz o sl s 59,58l b b |, sogas g bl bghas aslsi oo 2l oyl 45 : Ortho = FA
D9 0L Jloasgly bglas v 5 Cae o 390 oo el 3l ol - Polar Tracking = Fy o

Aok 5 03,5 B> I loyd Las S o 4 algs o LIl cpl 5l eslazsl L :Dynamic Input = FyY
« Polar Tracking 4 Ortho U 5l cpl auics poai axio 0 |, oSl slaply 5 (539,9 Sledlbl
S oo 5 sy
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XLINE ol B 3o s P B e utes ol Sl esliil -
Ribbon :Home tab» Draw panel » Construction Line Mb WLG‘J‘-?

Menu :Draw » Construction Line

Toolbar :Draw /

oo .
B3 Command entry :xline or x|

Ll Lzl BB g9, slasog, 51 (SO jgiws ol

Command: XLINE vl ) 5w (G121 =)
Specify a point or [Hor/Ver/Ang/Bisect/Offset]: - b 1S 0 lgicds dads SO 40,5 adein -V
SPECify tNrOUGN POINE: ooooeeeeerecceeeeeerrecsssssssesecessssssessseessssssssssssessssssssessseesssss pgd aladi 10,5 o)l Y
Specify through POINE: .o pow aladi 50,5 5l -
Specify through POINt: oo oylez alads 0 5 5 lg -0
SPECify throUGh POINE: oot oy aladi 18 ST lg -F

COMMANG: XLINE  ceeeeereeereceesusneeessssmnessssssmeesssssmesssssssesssssssmessssssnssssssssessessssnssssssnsessssssnessssssnsssssens gewd gl
Specify a point or [Hor/Ver/Ang/Bisect/Offset]: h ..o a8l a8 5l eolatl

;58 Hor —
S5 oo mmms 5 g g2 b 58 B8l s S S aseiea ) (slabai 45 i sl a3 ol 5l eolial

i35 Ver -
N
wawfw%@d#sor{alﬁb&’c..\.u.SGSJMbd‘dbmdsds.?w.«odb)b@;w‘)‘oéw‘b
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Slasle gbaisi g o5gil R D L

DS o 5 ol o B,k 90 Sl jatuine asgly b s G alg e a5 ol 5l eolaiwl b aggl; Ang -

ComMMEANd: XLINE  ceeeeeessmmmseessessmmssssesssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssasnasssssssssss D ygiwd gl
Specify a point or [HOr/Ver/ANg/BISECH/OMSE]: 8  rrrsrrimsrssimsssississsssieses, agly 43S
Enter angle of xline (0) or [REfErence]; 45 i Lz agly 0,5 0l
SPECGiy through point: s alads S 0,5 atein

leews Bisect -
S e ) sl wim b So sl 0l oe a5l sl eslasal b

Command: XLINE sy gosd (§]y2]
Specify a point or [Hor/Ver/Ang/Bisect/Offset]: p s Sl 435
SPECify angle Vertex point; aqly u*j) OO, At
Specify angle start point; = asly dlo sl 63, alais Sy 3,5 At
Specify angle end point; asl; c.La e (59, aladi S 0,5 ez

Start point

Vertex point

ol b slse o5 Offset

Command: XLINE Specify a point or [Hor/Ver/Ang/Bisect/Offset]: 0 «wwweeeeess Silge (5 anS
Specify offset distance or [Through] <30.0000>:  «oooovviivininivnnnnnes Silse oS alold 5,5 o lg
Select a ||ne ObJeCt .............................................................................. 09».) LSS CA.M.»‘ )‘]é 45 ‘SCWBA %JBLG‘
Spec|fy side to offset: o}w ﬁL?u‘ Lg.f S )‘)9 as N uo)f ua;v.w.a
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el ""’LQ"LS' & C)‘ L;l.e‘;l.u‘ ‘;5 B Q‘ L;‘..\S.g‘ as
Ribbon :Home taby Draw panel » Ray
Menu :Draw » Ray '//‘ o ‘)}‘ k)"b 979 L;LQL)’"?) )‘ é" a )3:'”"& U"‘

= Command entry :ray

COMMANG: RAY  ceerrrrrrmeesssssssmssssssssssssssssssssssssssssssssssssssssssss s ssssssssssssssssssessssssssssssssssssees Lgwd gl -
SPECify Start POINt: e Eoyis alads 10 S aseie -V
Specify through point: e 5,35 oo o) 59, 5 g oo oSS oz a5 glakais oS asuie -Y
Specify through PoiNt: e G alady 10,5 aseie -

Start point

KWLy los SO dusles wwd ool 3l solaiwl b -

= TRACE )‘95 PO - M;‘-’uﬁ-")ﬁ-’ - 9-&5" )5*-“’" A ) ‘
JSiS aygly awlez oo ez (g (o8 do 4 jets o

Sg ol Cde g § )0 adall SO dliad s asii 1) s

Command: TRACE e :)9.‘1...,.,‘) 6‘)9‘ -\
SpeC|fy trace width <1.0000>:3 e L 6[...9{' QJ)S ua.‘?g.wo -y
Specify start POINt: (1) e (V) £gyi alais 820 -V
SPECIfY NEXE POINE: (2) e seeessssessese s esees s (V) o aais 3,0 ¥
Specify next point: (3) , S (F) o 4o 5 jue -0

5

Start point
4 3

R
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CIRCLE ol Sl b1y o plo ailes o ygiws ol 5l oolaswl b -
DS w5 ] calisee bl 51 ledlb|

Ribbon :Home taby> Draw panel » Center ,Radius
ool 2] BB 520, slaghs) 5l (5o & g

| )Ja_9 Diameter |

T

Menu :Draw » Circle

Toolbar :Draw I"r"":h
L

-.- Command entry :circle or ¢ T

oﬁ‘o C‘f)

Command; CIRCLE  crrmeesssssssseeessssssssnsesenens el aliwgds 0 1o o )i 1 jgiwd (gl =)
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: ... o pls 35 0 40,5 astine Y
Specify radius of circle or [Diameter] <1.0000>: 2 rrmrrssmrrssnresineens opls glads 0,5 5,9 Y
! Radig S E88 g gy Jle 4

2
Command: CIRCLE  cerereesssmeesssissesssssessssssssssssssssssees s aliwgds 0 1o s i 1 gt (gl =)
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: ... opls 35 0 30,5 azin -V

Specify radius of circle or [Diameter] <1.0000 >: D

il oS 0,28 g 48 4T sl eslatwl gl D ST ol -Y
Specify diameter of circle <2.0000>:4 5 Jake 5 o s ¥

O, du..».{ RS 959, JL..O 4 3k

Y
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o) bame (59, alais aw il bopls o i TP (Three Points) -
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: 3P

Specify first point on circle: (1) . opls Lo (59, alaii gl 40,5 atie Y
Specify second point on circle: (2)

Specify third point on circle: (3) 1

b SO g, wlo aladi aw ol aS 0uS dxgi o

3P
2P (Two Points) —
Aol cﬁb )Ja_‘)).w 9 A;J‘sssn alags 9 Q.,J ‘oﬁlo NEYEN &9 alags 93 Q.';..islo L oﬁlo o

Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: 2P ... YP s 5 olbsesl -
Specify first end point of circle s diameter: ... opls Jhad slakads (Jgl 0,5 asein -Y
Specify second end point of circle's diameter:

................. ay‘.)).’aﬂ‘s:l;bmué; S =Y

2

2P
TTR (Tangent ,Tangent ,Radius)

el SO g wlew 90 (blo bopls g

Specify center point for circle or [3P/2P/Ttr (tan tan radius)l: TTR .. TTR as ;5 Gl -\

Specify point on object for first tangent of circle: ... opls wlas oydgl 305 asein Y

Specify point on object for second tangent of circle: .. 0515 Lolon ymagd (33,8 aseiue —Y

Specify radius of circle <1.8000 >: 2 opls glads 0,5 5 )lg - F

1 Radius=2

Radius=2 1

tan tan radius
Yy
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Ribbon: Home taby> Draw panel 3 Tan ,Tan ,Tan 2979 ployp bz )0 0 pls e i S h9) 9z

S L0 ) 5009, e Sel S ey 00l
Menu: Draw » Circle » Tan ,Tan,Tan

TTT (Tangent, Tangent, TANGENE) s oobes dus ilo Lo o w3 -
D4 a5 010 0 LS el olows Loy | 5 0 1o 45 gad90 dw (59, ol (B a5 ) Sl L

2
1
1 : JL..a ke
3
2 3

Center
Radius
1 2
S gl
Center , Radius 2P (Two Points) 4k 52
3
Tangent
1 2
abii 4w gp (Three Points) TTR (Tangent ,Tangent ,Radius)
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ARC GleS e IS o5 OleS Sl oo Hims Sl eslaal L
Oleyp b3 30 S e slaghy, 4o 9z

Ribbon :Home taby» Draw panel 3 3-Point S Byb ) et cpl el g o)l 979
Menu :Draw » Arc ooliinl (yloS pn 5 Ghgy 093k Sl 5 0S8 ‘)-'.’i:;‘

Toolbar :Draw f

= Command entry :Arc or a

;
(¥ g L=
Snet, Cinitind, DA

Sat, Covaes, agle:
s, Camtes, Langin

Lemt, End dngle

5wt End Domben
Samy, End Reden

Comvim, T, [
Gy, S, Sy

TAAS ATTR ARAD

oS Glasin -

E
£

;
4

Chord Length
bl akis End

oS 3, Center

o



Slosis b Lo i g o5 gil

COMMANG (ARG crreeeermsmieeesesssssssseessssssessssessssssssssasessssssssssssessssssssssssessssssssssnssssssees ObeS jews gl >l -)
Specify start point of arc or [Center]: e Ol Egypi aladi 0,5 jaseio =Y
Specify second point of arc or [Center/End]: - oS g aads 0 ST jastin -V
Specify end PoiNt Of @rC: e oS SLL ahis 0, asis . f

( Start' Center'End ) -
ObL 55y (g9 b alals Slaseiia (1Sl b (oS oo

OleS g9,% alali 3 5 aseie -)

ObeS 35 30 99,5 asine =Y
3 2 oS bl oS aseie Y
End 1

Center Start

( Start' Center ' Angle ) -
OleS g9y abai (0,5 azedis -

1 ObeS 3550 03,5 pasudee -V
Start oS agly 0,5 0)lg =Y

OleS aiS 3)ly (i 1) GleS sl ST
Center D9l g JoSLS uSe Zu 5o

( Start ' Center ' Length ) -
59 ok 55 e o, alali Slaseine (1Bl b GleS e 3
OleS g9,% alali (3 5 Azl -)
ObeS 35 30 9,5 asine =Y
OleS Sy Job 2,5 o)ls ¥
Length

Start

N

Center

s




o2k 515 9>y

( Start' End ' Angle ) -
42315 <0l < b 4l Dlasetin (18I b 0aS rms 5

Eoy alais 3,5 jasine =)
End v ! Sbb abis (50,5 Lasuive -V
’ Start OleS gl o5 )l ¥

( Start ' End 'Direction’) -
oy alais p oles Lo (L o8 abaki Slaseie 23 b Gl pen 5

30 R
S S (IR
/,(')'o

Sz Gess -V
End Start

( Start' End 'Radius ) -

el (Ll gy alads Olasein (il b LS s )3

QLJ&)&MQo;QM—\

2 o 1 Okl ahd (9,5 (asie =Y
<
®

Ol gy 9 39800 S OleS Cuz WS O)lg wSen | (L g g9y0 abali gl 2l Gl ST

( Center ' Start 'End ) -

OS5 30 59,5 pasie -
; Eort ahail (13,5 jasie -V

g ol alais 55,8 asie Y

Start

Center
v
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( Center ' Start 'Angle )
gl (Eay Sy aladi Slaswine dlo b GlaS guw )i

S 550 525 )

2 OleS 58 53,5 At Y
. Start OleS asgly 0,5 o0,le =Y
1
Center

( Center ' Start 'Length ) -
59 Jsb g £9,8 5 e Slagin (Lol b (leS a3

3 OleS S0 (53,5 i -)
Length E OleS 9,8 alali (3 5 [aseie -V
>1</\Start 79 sk 0,5 olg =Y

Center

( Continue ) -
OO 3y b g o9 ce Jog GLeS L a3 g5 5l o v 5 abas (3T 4 093 leS g (g cnl o
223 oo bl o> 5 4 gum abads
Command: _arc . .l 2
g oo ey 4l 90 b oleS (l @Bl 5o
Specify start point of arc or [Center]:

Specify end point of arc:

2
1 /2 1
End start Y End Start

Line or Pline or Arc

\ / S o5 5ied Cnl lage, Sl S bl e 5l S e

A
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PLINE S>> e ) Sty Ol b b s g o Hews pl 5leslaul b -
kS s Jos o2 @ izl () 45 05 oy oo e
Ribbon :Home taby Draw panel » Polyline slcwbes L Q‘53t5'° I b o pl wbl o

Menu :Draw » Polyline b j cles QBSLSA LS:}‘)“' J Q; o M
. g ol 1 o]
Toolbar :Draw ___ %

= Command entry :pline or pl

COMMAN: PLINE oo sssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssses g gl =)
S T e 11 A 21 0] 1| R ———— Jol alais 0 S jasie -Y
Current line-width is 0.0000  wswsssssssssssssssssssssssssssssssssssssssssssssssssssssssssssees ShFais Cubs 1 158 &l
Specify next point or [Arc/Halfwidth/Length/Undo/Width]: 4 - pgo ki 0,5 jasie -

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: 2 9~ aladi 0,5 jasie -¥
Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: 4 = -eeeeeeeeeeeeee o ke aladi -0

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: C
Lol alass g locul aads e 9 C 2SS 51 oolizwl L -#

. L=4 2 .
next point next point
-—

o\ o\
I * * I
— —

Close X_start point

4 —» 1 Arc —

Ol jeiwd (slaysild dan auS eolaiul 50 leS 5l edad a5 a0 j0 wlg o 43T ol 5l eslaial b
A5l glawas Lol 4o

Close —
Al albls dny datais SO ales o 43S ol 5l eslatll

Halfwidth —
DS asin |y s Culis aal 0lgs oo 4 S cpl 5l eolaiul
Specify starting half-width <2.5000>:3 ... AuS jasie £oyh a0 |y Sl aai )
Specify ending half-width <3.0000>: ... S aseie Gbl ahds o) cwlho aai -Y

- j: Halfwidth

4



e gl 5 055 S

Length —
S8 ol b Job 4 (L8 b 5wl e b e 5 0o 5 a5 Gl sl ool L

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: L ... Job 435 5l eolazul

Specify length of IN€: 20 s aS ole 1y das Job o adlsl jlade

/’/
1 2 Undo —

28,5 5l e 4y Al e S als oo 43Sl Sl oslaal b

Width —
WSS 0lg 1y b culs S ailgs oo a5l 5l eslal b

Specify next point or [Arc/Halfwidth/Length/Undo/Width]: W _.ooooooe..... Ly 43S 5l oolaul
Specify starting width <1.0000>: 3 il e Sslite wa b bl 5 £grd 5o b s Jlie cpl 4o
Specify ending width <3.0000>: 8

Starting width = 3 i ‘ :]:E”ding width = 8

Specify starting width <3.0000>: 8 el sl il 5 oy Al s L caali e ol o

Specify ending width <8.0000>: 8

Specify starting width <8.0000>: 0 alais 5 5 yho £oyd alas o b Cuslis e ol o
Specify ending width <8.0000>: 8 bl se St SLLG

ol oad pg e S LSas el b i Jlie oy

Starting width = 0 < :]:Ending width = 8

Do
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RECTANGLE ax LS Jibies & b dhins alg go jeiws (pl 5l eolasal b
S o 5 Az LSS

Ribbon :Home tab» Draw panel » Rectangle

Cwlylo 1) o Jadaiz cools gy o)
Menu :Draw » Rectangle ’

Toolbar :Draw E

cm 3
o Command entry :Rectangle or rec

Command: RECTANG s ssssssssssssssssssssssssssssssssssssssssssssssssssssssssns Hgewd gl =)

Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]:
o,z adsS gl (9,5 ateie Y
Specify other corner point or [Area/Dimensions/Rotation]: @70,30
ol 00l oolainl s g, 3l ] jo (pgd dlgS 0,5 asuine -Y

2/ @70,30

o
M

First corner

70

—4—

——

Area
S 5 E5ose cerbas (5558 85 b el 45l 1) ako Loz ol Lo a5 il a3 ol 51 oolial L
D9l oo o (o2 ez e ]

Specify other corner point or [Area/Dimensions/Rotation]: A ... Colune 435 olasl -)

Enter area of rectangle in current units <230.0000>: 120
ool AdST 10 188 g Coluce (0,5 o)lg Y
Calculate rectangle dimensions based on [Length/Width] <Length>: L
Ao Slas ) ol adS awm g ]y oye b aaS o)lg 1) b aales o auS asein -V
Enter rectangle length <22.0000>: 10 e AS 8lg |y Jsb Jlade -F

S=120m’
1
10

First corner

O



Sl slaaiils 5 o5l P
Dimensions —
S bl IS cam calyd 10 g 00uwp alBlax 1) oy g Job ade wSgl an S ol 5l ool b

Specify other corner point or [Area/Dimensions/Rotation]: D ... Lo 31l ass 35 el - )
Specify length for rectangles <20.0000>: 22 v Jsb Jlade 50,5 o,lg -Y

Specify width for rectangles <15.0000>: 16 e 2 lade 0,8 5 lg =Y

Specify other corner point or [Area/Dimensions/Rotation]:
MSWLNQ&AJPL‘)GA@)LQ}MP—\C

£
To
= 1
First corner
22
length
Rotation -
Ot asly b (ldjlez (b o B oS o)y ) (bl 2552 jlade wilgs e S cnl sl eslaal b
Sg o i 00D
Specify other corner point or [Area/Dimensions/Rotation]: R ... LSy a5 ol -
Specify rotation angle or [Pick points] <0>: 45 s agly Jlade 43,5 o)lg =Y
Specify other corner point or [Area/Dimensions/Rotation]: oo Jgl &S 18,5 Laseine =Y
Command: SpGley Opposite COMNEL: coeerecesermsommamsinnsstssimmetssamssssuasstssassssssassssssass £y M; uo; 9)15 -f

First corner

oY
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Chamfer —
3l & s O slaaiss a5 w3 ol ez il a3 Cal 5l eslial L

Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: C a3 ol -
Specify first chamfer distance for rectangles <56.0000>: 8 ... Zo alold gl 0,5 o)l =Y

Specify second chamfer distance for rectangles <5.0000>: 8 & alols ego (0,5 o)ls =Y
8

‘_\ First Distance

OOT Second Distance

Fillet —
Aol alils o5 sledaisS a5 auS e i 2o i ».\.u‘s.:‘sc ‘&L’..is Sade pudaid g a5 ol 5l eolaiul b

Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: F an;S ol -)

Specify fillet radius for rectangles <8.0000>: ... absS 5,5 el Jade 0,5 5 )ls =Y

=)
Fillet Radius

Width —
IS e S |y (o lez bglas ailgh o a5 cpl 5l eolaul L
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t’ Menu : Format » Drawing Units

= Command entry : units

— e dxlg = aaes aly - (g lexs wxlg

‘ ‘ oo SO el Gl s ol
- 185007
Architectural ,Decimal ,Engineering ,Fractional,
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ERASE  lgsase o5 S b i
2 L Modify g4y ajgiws opl 4sn

Ribbon :Home tab » Modify panel 3> Erase Mb o S5 a0 MOdlfY Panel

Menu :Modify » Erase

Toolbar :Modify f Ll B g9, sl g, 5l (SO A jeiws ()
Shortcut menu :Select the objects to erase , “\“‘L’ T
and right-click in the drawing area .Click Erase.
Command entry :erase or e
Command: ERASE e nes Y vOWR 6‘)-'." -\
Select ObjeCtS: 1 fOUNG oo (&9.@5.@ S9, gS.JS) &9.@3.@ U"Jﬁ‘ ul?w‘ -y
Select objects: 1 found, 2 total ..., Eab90 Cymogd ol -Y
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Ribbon :Home tab» Modify panel > Copy
Menu :Modify » Copy w‘ ‘P‘ J.tlﬁ 9)4"5) GL‘”u’"ﬁ) )‘ L;" b )9:"“") L)"‘
Toolbar :Modify ':-f',;

Shortcut menu :Select the objects to copy ,
and right-click in the drawing area .
Click Copy Selection.

Command entry :copy or co

COMMEANd: COPY  commsssemmsssmsssssssssssmsssssssssssssssssssssssssisssssss s s sssss gewd gl =)
Select objects : 1 found s (Egog0 bl Globs,) bEgoge b ggoge wlswl -Y
SElECt ODJECES i ooveeeececeieveveisssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssnnes sl oS 0,8 L el ML: _y
Current settings : Copy mode = Multiple s oS g it 5l 1S &)

Specify base point or [Displacement/ mOde] < Displacement>:

S o sl (lgreas abais S Ol Y

Specify second point or <use first point as displacement >:

S 7o ahts flgiedas pgo alais CLsl -0

Specify second point or [Exit/Undo] < Exit >:
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Ribbon :Home tab » Modify panel » Move
T ——— el 12l BB g g5 slashe, 51 S b ygims
Toolbar :Modify —E-.-

Shortcut menu :Select the objects to move ,
and right-click in the drawing area .
Click Move.

Command entry :move or m

Command: MOVE vttt ettt )G LS‘)" -\
Select ObJeCtS 1 found ................................ (&9@5.0 AT)l?L;.J" Glﬁwa)) lﬁws& l% 69.&5.& ;'Al?c.u" —Y
SEIECt ODJECES : ot Sl oS 0,28 b el b ol al -

Specify base point or [Displacement | < Displacement>:
s sl lyea abis S Sl -F

Specify second point or <use first point as displacement >:
Qaie aadi lgieds pgo alats Ol -0

base point
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Ribbon :Home tab » Modify panel » Mirror 2,5 oolaiwl jaiws cpl 5l les o il o
Menu :Modify » Mirror )
Toolbar Modity /]l 2l Glhas jyiwd cnl jo CoS anl lgd

Command entry :mirror or mi

Command MIRROR .................................................................................................................... 1)9:».».00 6‘)?‘ —\
Select objects 1 1 fouNd e lggoge b goog0 ool =Y
SeleCt ODJECES & v il oS 0,8 b ol ML -y
Specify first point of Mirror iNe: e anl s sl adads fpdgl 0,5 asin -
Specify second point of mirror line: ..l anl sl adas fpegs 43,5 Lasuie -0
Erase source objects ? [Yes/ No] <N>: S o i
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Ribbon :Home tab » Modify panel » Rotate

Menu :Modify » Rotate JB g,y sloss, 5l o 5l eslaul b g (5l
Db o 1y
Toolbar :Modify O et T

Shortcut menu :Select the objects to rotate ,
and right-click in the drawing area .Click Rotate.

Command entry :rotate or ro

Command: ROTATE s )G LS‘)'." -\

Current positive angle in UCS : ANGDIR = counterclockwise ANGBASE =0 )
O9d &30 9 090 Lz 9,90 50 (5,155 &l

Select objects : Specify opposite corner : 1 found legoge b gaoge ool -¥
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Specify rotation angle or [Copy/ Reference] <0>:90 e e asgly 9,5 8 )ls -0
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base point
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Ribbon :Home tab » Modify panel » Offset
Menu :Modify » Offset
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STRETCH lggoge (Sois P 1y lgsdse ail oo jaiws nl 5l ool L
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Ribbon :Home tab » Modify panel » Stretch
Menu :Modify » Stretch

Toolbar :Modify E

Command entry :stretch or s

Command: STRETCH  rrereeeerrersssssssssmmsssssssssssssesssssssssssssssssssssssssssssssssssssssssssssssssssee fgewd gl =)

Select objects to stretch by crossing-window or crossing-polygon...
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Select objects: Specify opposite corner: 1 found .o, Eaog0 oLl =Y
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Specify base point or [Displacement] <Displacement>: ... b alai 0,5 jasin -F
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Toolbar :Modify HH

Command entry :array or ar
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SCALE R - Sl slaggoge auiles oo jgiws (pl 5leolaiul b
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Ribbon :Home tab » Modify panel » Scale 09,...;‘5@ 1)_?1 929, dlﬁui’j) ).| é-‘ b 5w Q—.’.‘

Menu :Modify » Scale
. e |
Toolbar :Modify DJ

Shortcut menu :Select the objects to scale ,
and right-click in the drawing area .Click Scale.

Command entry :scale or sc

COMMANG: SCALE e smsssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssee g gl - )
Select ODJECtS: 1 FOUNT s loggoge b ggog0 ol =¥
SEIECE ODJECES: ottt Sl 0S8 b beobesl ol -
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Specify scale factor or [Copy/Reference] <1.0000>: 2
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Specify scale factor or [Copy/Reference] <2.0000>; C  wwrwersemssesssssssese S A bl

Scaling a copy of the selected objects .
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Ribbon :Home tab » Modify panel » Trim B g9, lo g, 31 (SO 5l eolaiwl b giws oyl
Menu :Modify » Trim wob oo 12l

Toolbar :Modify .-J.n'.-_

Command entry :trim or tr
CommaNd: TRIM e ssssssssss s sssssssssssssssssssesssssssss JYVORREPJEH B

Current settings: Projection=UCS, Edge=None s~ (2l ool nulais slo it 51 3,155 &1 |

Select cutting €dges ... s0 2Bl 8,90 40 WSl sy
Select objects or <select all>: 1 found s ON e ol =Y
SEIECE ODJECES: oo Sl ol e 28 b ol an b -
Select object to trim or shift-select to extend or Dgd Bl aublys o a5 ted bl -F

[Fence/Crossing/Project/Edge/eRase/Undo]: ’ 2’ ’
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[Fence/Crossing/Project/Edge/eRase/Undo]: f ..o ool Feileczcijfgbwl
Specify first fence PoiNt: e ssessiaanns 00, 3l akads gl 08 e
Specify next fence point or [UNdo]: o (pgo ahad)) (gawy aadi 10,5 jastiv
Specify next fence point or [UNdo]: e (pyw abai) o alaili 15 S Azl

>4< >< Fence

X

Project —
Al doles 00ls sl (gum dw ol o

Edge —
Al aeles ol g el 43S ol 5leslawl b
[Fence/Crossing/Project/Edge/eRase/Undo]: e O e SeeSe ol

Enter an implied edge extension mode [Extend/No extend] <No extend>:

. Extend —
Al aslo ébl.@.* gy bl o> Gglpw’ | £ gS90 ;s Q.l‘ ol b
No extend —
eRase —
DS SU 1) cilisee slaggoge b gaoge duilys oo joimws Gl Gloy ,o asS ol bl b

[Fence/Crossing/Project/Edge/eRase/Undo]: r

Select objects to erase or <exit>: 1 found ) _
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EXTEND ro < b goipn 4 i, 0275 €9250 e s5ied Gl jleslitl -
S5l 4 baio e ool ales o a5 (65,0 U
Ribbon :Home tab . Modify panel 3, Extend E3:050 Jawsg 3l Haww) Cuz 4 gadge Sl e

Bad plol Gl ) e Comods
Menu :Modify y, Extend F Rl e BE i

Vel Tl oty S yuio Extend o Trim jgiws (glogulass :asgis
Command entry :extend or ex il oo alin g
CommaNnd: EXTEND i yghwd Ls‘)"’" -\

Current settings: Projection=UCS, Edge=None  ,guwo (2l ool pdais slo punito 51 5,155 &1

Select boundary €dges ... s 3% ol 90 4O .,\59.3" Toog
Select objects or <select all>: 1 fOUNG o Oy a0 o=l =Y
Select ODJECES: e s ol adS” o s b o] ..\.._:L =Y

Select object to extend or shift-select to trim or ey j 0 4 aples 0 a5 codg0 ol -f
a5 b 1) Shift oS > cpl jo 31 .08 solitul ead S ggog0 bl slael, oles 51 alys oo
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BREAK Oy Iy 2Bl ggoge auily co jgiws (pl 5l eolanul b
Al ggog0 90 4 g 0iSiy alall g0 b SO
Ribbon :Home tab » Modify panel » Break A_._.S J_.M

Menu :Modify . Break

Toolbar :Modify

Command entry :break or br

COMMEANG: BREAK ~ rreeeeeesseseesssessessssess s s s 5858858 Hgiwd gl
Select ObJect : i (S5 oo Cgme CanSlls gl alaii calads pl) fadge bl )
Specify second break point or [First point]: e CanSls pgo alads Gl -Y
1 2
N - -

Specify second break point or [First point]: f First Point —
S Ol 6,bg 1, gl abais cogga el i3 ol ol

Specify first break point: oo ConSlsy adady oyl Gl -)
Specify second break point: s ConSlls adadl pogs ol -Y
2 1
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first line

1
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—
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1 2 \I ] 2
—> —>
Polyline —

S Jloel loaissS wan (53, |y ¢ 9l o0 2l 42 LSs Lo £5050 45 S50 50 43 (nl  eslital L
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Command: CHAMFER
(TRIM mode) Current chamfer Dist1 = 40.0000, Dist2 = 40.0000
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Agld 7yl jews g awsS bl 1) S glaads b pais ailed co a5l 5l eolaiul b
1

m2 4 p2 m2 —p m

qy

O




s o o 81Ty A

FILLET A5 5 sl 90 SN Jowo yo M‘ysn S5 cpl 5l eslatal b
Ribbon :Home tab » Modify panel » Fillet 3 S yuie Chamfer b jgiws L.),1 GLQ S 55
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colbar Standard = Jil 1 reolys sumlys o a8 g0 il -Y
Command entry :matchprop or painter Select source object: R

Select destination object(s) or [Settings]:

Settings —
Loy 0o 5L g9, yolSan ;S cpl 5l eolaiul b -
el HIS I LT (59, 5w a5 (6950 wlsS (o0
Color Layer Ltype Ltscale Jbd e b oo S ovalin )
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Indicate dimension point to remove, or [Add/eXit] <eXit>:
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Ribbon :Annotate tab » Dimensions panel »Baseline

Menu :Dimension »Baseline

Toolbar :Dimension t:' U oL
= Command entry :dimbaseline
Command: diMbaseliNg ...ttt Hgewd gl =)
Specify a second extension line origin or [Undo/Select] <Select>: ... pgo alass Ll -Y
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Specify a second extension line origin or [Undo/Select] <Select>:
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Ribbon :Annotate tab)» Dimensions panel » Adjust Space
Menu :Dimension »» Adjust Space
Toolbar :Dimension :[E:

gm i
P Command entry :dimspace
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Select dimensions to space:Specify opposite corner: 3 found
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Dimension Style» Modify or override » Lines Tab » Dimension Lines» Baseline Spacing
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Toolbar :Dimension JL .

Menu :Dimension » Dimension Break

= Command entry :dimbreak
Command: DIMBREAK s ygiand (gly>l =)
Select dimension to add/remove break or [Multiple]: .......... Dg adad Wb aS sloslasl el -

Select object to break dimension or [Auto/Manual/Remove] <Auto>:
Sg adad b S 1 4 Cod Wb ojlail &S e g0 sl =Y
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Dimension Style » Symbol and Arrows Tab » Dimension Break» Break Size
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Ribbon :Annotate tab y» Dimensions panel 3 Center Mark 1 1
Menu :Dimension » Center Mark
Toolbar :Dimension | - ;

= Command entry :dimcenter

center marks center lines
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DIMJOGLINE ~ (5ls ausl) o5, sl

Ribbon :Home tab » Annotation panel » Jog Line

Menu :Dimension » Jogged Linear

[T Command entry :dimjogline
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Ribbon :Annotate tab» Dimensions panel» Oblique

Menu :Dimension» Oblique

Toolbar :Dimension ¥ Dimension Edit ,Oblique .*j'
L

Command entry :dimedit
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Ribbon :Annotate tab » Dimensions panel »Text Angle
Menu :Dimension » Align Text Angle
Toolbar :Dimension | A

= Command entry :dimtedit

Command: dimtedit e
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Dim: up OO UU TN
Select ObJeCtS 1 found ..................... A.H.S ul?b..)‘ IRVELY J.u..x.: M‘P(SA aS ‘) G,L:oo)b;‘ 6AL0~J -Y

09“’6" ﬁl;u‘ LQO)L.M‘ k&a.ud u‘*ﬁ*—’ c)..u..:‘ J..a_lf uo).....e l;—\c

2.0000 200

before Update after Update
style=Standard —_— style=CM

P oy pod

..S...‘S Lg)‘b\fo)‘..ﬂ ‘) cd,{‘oo; f""‘“’)” [“)Lér? )lS ..\.‘>‘9 )b4\5|) 6‘ 035).&—\

S ooliil olgz LIS g oas (6,138 05lul glaats 5l wilgi oo 551 lsie 4 LS ol ol

\AF



M” W )‘S »‘9

W aely bl ol 435 )l ©YIgw digos

g 50 ALl v S b dsgly (6,138 olasl -
Dimension- Angular (o Dimension-Ordinate(.!
Dimension-Radius (s Dimension-Center (z

fog0i (5,005 o3lail ]y o pls G Hlad  lg5 co 4ty 35 plas L -Y
Radius (& Diameter (.l
Linear (s Angular-

.................. ol o Dimlinear jgws 5l sslazal b -Y
Sl alol (g3g0s (6,105 o3l lg8 oo add (o Lol plol 281 (6 135 oslail e o Jadd (A
Slo plil aygly >y 1, (6,185 oslail (o olo plxil (5,185 o5lasl 281 ¢ (s050e &0 (z

2 JolS jebds |y ey g0 alads 50y alold oo ol e TeXt jgiws gl o 435 slas” Clsesl -f

il oo ool (e glis )] (g 035 oo
Justify (s Insert (z Align (o Fit (I

Sa,ls o5 ax Dimedit ,gws -0
S oIl L b ysis (21 0058 s (o Lo 13501l gl (ll
SISl 4y b ye slo il s (0 G NS o3Il S i (2

0,105 oo Sl pj sloan ;5 51 SO plas gg, (Ddedit) -¢
Dimension (s Polyline ( Text (& Hatch (wl

Fogu oo oolaiwl jgiws plas 5l (g liligl S 90,5 aseie jolaiedy cungi yie slp =Y
Upside down (s Backward (z Font (& Text style (.l

(s (somigh e ol 50 JUSHEY (Gutyjl 5 oy bgyje a3 plas -A
End point (o Middle Fit (& Center (!

\AY






W )lS »‘9

I

G.
5

:,_;)L‘.é) ‘SLQ -RV-3
1ilgiy wuly HI aolg cpl (il )57 51 g 51,8

oyl e el

YAQ




Sloaslo gaisi g o5eil R D

LsL{aoLi';...:o o oS 6[&00[.&.1...4‘ 6‘)% )‘}fﬂ ey Q—.’.‘ oS 6[.:»6?9)5 c.)Sjb" le.@w R o )'l L;i:
w3l (o ol 5 silene 4y y3 oag 4 Wil a i 6900 5 sl 408 Slr &5 Wil SleiS b g Saio
G aiE lr st S 5 4l syree claaih oy & wb gleibls S cole Jole ol
e Hez bl e AEl glad g Jow slad i oS gl Lol e 9o 4o Plotter o Printer ali.,
ools Guay odLmJ.i.u AJJJ.AJQJ.ZAJO uL? daj)d.fw| QT).: S oS w)m d..clSLsLa.S UL.S
wopmé g AY LAY ,ol5 O e .oumo

PLOT el
Ribbon :Output tab » Plot panel »Plot ° ‘) Ul" g LS‘)’.'| LSL"’ui’B)
Menu :Application menu » Print 3 Plot B ’ e L

Toolbar :Standard @
Shortcut menu :Right-click the Model tab or a layout tab and click Plot.
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